Здравствуйте Гость [ Вход | Регистрация ] | Форум в сети 4843-й день

 Что за ошибки при обновлении kubuntu 18 ?

mstdmstd
Nov 28 2018, 19:19
  
Пост #1



Репутация:   1  
Дух


Группа: Пользователи
Сообщений: 181
С нами с: 13-January 16


Всем привет!
Я пытался обновить свою kubuntu 18 и получил ошибки :
CODE Format
$ sudo apt-get update
[sudo] password for serge:  
Ign:1 http://dl.google.com/linux/chrome/deb stable InRelease
Hit:2 http://ua.archive.ubuntu.com/ubuntu bionic InRelease                                                                                                                                                            
Get:3 http://ua.archive.ubuntu.com/ubuntu bionic-updates InRelease [88,7 kB]                                                                                                                                          
Get:4 http://security.ubuntu.com/ubuntu bionic-security InRelease [83,2 kB]                                                                                                                                            
Hit:5 http://ppa.launchpad.net/clipgrab-team/ppa/ubuntu bionic InRelease                                                                                                                                              
Get:6 http://dl.google.com/linux/chrome/deb stable Release [943 B]                                                                                                                                                    
Get:7 http://ua.archive.ubuntu.com/ubuntu bionic-backports InRelease [74,6 kB]                                                                                                                                        
Hit:8 https://repo.skype.com/deb stable InRelease                                                                                                                                                                      
Get:9 http://dl.google.com/linux/chrome/deb stable Release.gpg [819 B]                                                                                                                                                
Hit:10 https://deb.nodesource.com/node_10.x bionic InRelease                                                                                                                                                          
Hit:11 http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu bionic InRelease                                                                                                                                          
Hit:12 http://ppa.launchpad.net/webupd8team/java/ubuntu bionic InRelease                                                                                                                                              
Ign:13 http://packages.elastic.co/elasticsearch/2.x/debian stable InRelease                                                                                                            
Get:14 http://ua.archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages [443 kB]                                                                                                      
Ign:15 http://ppa.launchpad.net/webupd8team/sublime-text-3/ubuntu bionic InRelease                                                                                                                                    
Hit:16 http://packages.elastic.co/elasticsearch/2.x/debian stable Release                                                                                                                                              
Get:17 http://ua.archive.ubuntu.com/ubuntu bionic-updates/main i386 Packages [393 kB]                                                                                                                                  
Get:18 http://ua.archive.ubuntu.com/ubuntu bionic-updates/main Translation-en [166 kB]                                                                                                                              
Get:19 http://ua.archive.ubuntu.com/ubuntu bionic-updates/main amd64 DEP-11 Metadata [233 kB]                                                                    
Get:20 http://ua.archive.ubuntu.com/ubuntu bionic-updates/main DEP-11 64x64 Icons [103 kB]                                                                          
Get:21 http://ua.archive.ubuntu.com/ubuntu bionic-updates/main DEP-11 128x128 Icons [249 kB]                                                                  
Hit:22 https://download.sublimetext.com apt/stable/ InRelease                                                                                                    
Err:23 http://ppa.launchpad.net/webupd8team/sublime-text-3/ubuntu bionic Release                                                                                
  404  Not Found [IP: 91.189.95.83 80]
Get:24 http://ua.archive.ubuntu.com/ubuntu bionic-updates/universe i386 Packages [574 kB]                                                
Get:25 http://ua.archive.ubuntu.com/ubuntu bionic-updates/universe amd64 Packages [579 kB]                      
Ign:26 https://artifacts.elastic.co/packages/6.x/apt stable InRelease                                              
Get:27 http://ua.archive.ubuntu.com/ubuntu bionic-updates/universe amd64 DEP-11 Metadata [195 kB]                  
Get:28 http://ua.archive.ubuntu.com/ubuntu bionic-updates/universe DEP-11 64x64 Icons [316 kB]                                
Get:29 http://ua.archive.ubuntu.com/ubuntu bionic-updates/universe DEP-11 128x128 Icons [764 kB]                          
Hit:30 https://artifacts.elastic.co/packages/6.x/apt stable Release                                                          
Get:31 http://ua.archive.ubuntu.com/ubuntu bionic-updates/multiverse amd64 Packages [6 364 B]                      
Get:32 http://ua.archive.ubuntu.com/ubuntu bionic-updates/multiverse i386 Packages [6 520 B]
Get:33 http://ua.archive.ubuntu.com/ubuntu bionic-updates/multiverse amd64 DEP-11 Metadata [2 468 B]
Get:34 http://ua.archive.ubuntu.com/ubuntu bionic-backports/universe amd64 DEP-11 Metadata [5 104 B]
Reading package lists... Done                                                  
E: The repository 'http://ppa.launchpad.net/webupd8team/sublime-text-3/ubuntu bionic Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.                                                                                                                                    
E: Repository 'http://dl.google.com/linux/chrome/deb stable Release' changed its 'Origin' value from 'Google, Inc.' to 'Google LLC'                                                                                    
N: This must be accepted explicitly before updates for this repository can be applied. See apt-secure(8) manpage for details.                                                                                          

$ sudo apt-get upgrade                                                                                                                                                    
Reading package lists... Done                                                                                                                                                                                          
Building dependency tree                                                                                                                                                                                                
Reading state information... Done                                                                                                                                                                                      
Calculating upgrade... Done                                                                                                                                                                                            
The following packages have been kept back:                                                                                                                                                                            
  docker.io libegl1 libgl1 libgl1:i386 libgles2 libglvnd0 libglvnd0:i386 libglx0 libglx0:i386 plasma-discover plasma-discover-common                                                                                    
The following packages will be upgraded:
  git git-man libjavascriptcoregtk-4.0-18 libsmbclient libwbclient0 libwebkit2gtk-4.0-37 nodejs openjdk-11-jre openjdk-11-jre-headless openjdk-8-jre-headless samba-libs
11 upgraded, 0 newly installed, 0 to remove and 11 not upgraded.
7 not fully installed or removed.
Need to get 15,0 MB/107 MB of archives.
After this operation, 77,8 kB of additional disk space will be used.
Do you want to continue? [Y/n] Y
Get:1 https://deb.nodesource.com/node_10.x bionic/main amd64 nodejs amd64 10.14.0-1nodesource1 [15,0 MB]
Fetched 15,0 MB in 3s (4 898 kB/s)    
(Reading database ... 267959 files and directories currently installed.)
Preparing to unpack .../00-libsmbclient_2%3a4.7.6+dfsg~ubuntu-0ubuntu2.5_amd64.deb ...
Unpacking libsmbclient:amd64 (2:4.7.6+dfsg~ubuntu-0ubuntu2.5) over (2:4.7.6+dfsg~ubuntu-0ubuntu2.4) ...
Preparing to unpack .../01-samba-libs_2%3a4.7.6+dfsg~ubuntu-0ubuntu2.5_amd64.deb ...
Unpacking samba-libs:amd64 (2:4.7.6+dfsg~ubuntu-0ubuntu2.5) over (2:4.7.6+dfsg~ubuntu-0ubuntu2.4) ...
Preparing to unpack .../02-libwbclient0_2%3a4.7.6+dfsg~ubuntu-0ubuntu2.5_amd64.deb ...
Unpacking libwbclient0:amd64 (2:4.7.6+dfsg~ubuntu-0ubuntu2.5) over (2:4.7.6+dfsg~ubuntu-0ubuntu2.4) ...
Preparing to unpack .../03-git-man_1%3a2.17.1-1ubuntu0.4_all.deb ...
Unpacking git-man (1:2.17.1-1ubuntu0.4) over (1:2.17.1-1ubuntu0.3) ...
Preparing to unpack .../04-git_1%3a2.17.1-1ubuntu0.4_amd64.deb ...
Unpacking git (1:2.17.1-1ubuntu0.4) over (1:2.17.1-1ubuntu0.3) ...
Preparing to unpack .../05-libwebkit2gtk-4.0-37_2.22.4-0ubuntu0.18.04.1_amd64.deb ...
Unpacking libwebkit2gtk-4.0-37:amd64 (2.22.4-0ubuntu0.18.04.1) over (2.22.2-0ubuntu0.18.04.2) ...
Preparing to unpack .../06-libjavascriptcoregtk-4.0-18_2.22.4-0ubuntu0.18.04.1_amd64.deb ...
Unpacking libjavascriptcoregtk-4.0-18:amd64 (2.22.4-0ubuntu0.18.04.1) over (2.22.2-0ubuntu0.18.04.2) ...
Preparing to unpack .../07-nodejs_10.14.0-1nodesource1_amd64.deb ...
Detected old npm client, removing...
Unpacking nodejs (10.14.0-1nodesource1) over (10.13.0-1nodesource1) ...
Preparing to unpack .../08-openjdk-11-jre_10.0.2+13-1ubuntu0.18.04.4_amd64.deb ...
Unpacking openjdk-11-jre:amd64 (10.0.2+13-1ubuntu0.18.04.4) over (10.0.2+13-1ubuntu0.18.04.3) ...
Preparing to unpack .../09-openjdk-11-jre-headless_10.0.2+13-1ubuntu0.18.04.4_amd64.deb ...
Unpacking openjdk-11-jre-headless:amd64 (10.0.2+13-1ubuntu0.18.04.4) over (10.0.2+13-1ubuntu0.18.04.3) ...
Preparing to unpack .../10-openjdk-8-jre-headless_8u191-b12-0ubuntu0.18.04.1_amd64.deb ...
Unpacking openjdk-8-jre-headless:amd64 (8u191-b12-0ubuntu0.18.04.1) over (8u181-b13-1ubuntu0.18.04.1) ...
Setting up git-man (1:2.17.1-1ubuntu0.4) ...
Setting up libwbclient0:amd64 (2:4.7.6+dfsg~ubuntu-0ubuntu2.5) ...
Setting up samba-libs:amd64 (2:4.7.6+dfsg~ubuntu-0ubuntu2.5) ...
Processing triggers for mime-support (3.60ubuntu1) ...
Setting up nodejs (10.14.0-1nodesource1) ...
Setting up lvm2 (2.02.176-4.1ubuntu3) ...
update-initramfs: deferring update (trigger activated)
Failed to restart lvm2-lvmetad.service: Unit lvm2-lvmetad.socket is masked.
invoke-rc.d: initscript lvm2-lvmetad, action "restart" failed.
● lvm2-lvmetad.service - LVM2 metadata daemon
   Loaded: loaded (/lib/systemd/system/lvm2-lvmetad.service; static; vendor preset: enabled)
   Active: inactive (dead)
     Docs: man:lvmetad(8)
dpkg: error processing package lvm2 (--configure):
installed lvm2 package post-installation script subprocess returned error exit status 1
dpkg: dependency problems prevent configuration of libguestfs0:amd64:
libguestfs0:amd64 depends on lvm2; however:
  Package lvm2 is not configured yet.

dpkg: error processing package libguestfs0:amd64 (--configure):
dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
                                                                                                          Setting up openjdk-11-jre-headless:amd64 (10.0.2+13-1ubuntu0.18.04.4) ...
dpkg: dependency problems prevent configuration of libguestfs-reiserfs:amd64:
libguestfs-reiserfs:amd64 depends on libguestfs0 (= 1:1.36.13-1ubuntu3.2); however:
  Package libguestfs0:amd64 is not configured yet.

dpkg: error processing package libguestfs-reiserfs:amd64 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libguestfs-perl:
libguestfs-perl depends on libguestfs0 (= 1:1.36.13-1ubuntu3.2); however:
  Package libguestfs0:amd64 is not configured yet.

No apport report written because the error message indicates its a followup error from a previous failure.
                                                                                                          No apport report written because MaxReports is reached already
                                                                                                                                                                        dpkg: error processing package libguestfs-perl
(--configure):
dependency problems - leaving unconfigured
Setting up libsmbclient:amd64 (2:4.7.6+dfsg~ubuntu-0ubuntu2.5) ...
Processing triggers for libc-bin (2.27-3ubuntu1) ...
Processing triggers for man-db (2.8.3-2ubuntu0.1) ...
Setting up libjavascriptcoregtk-4.0-18:amd64 (2.22.4-0ubuntu0.18.04.1) ...
Processing triggers for hicolor-icon-theme (0.17-2) ...
Setting up git (1:2.17.1-1ubuntu0.4) ...
dpkg: dependency problems prevent configuration of libguestfs-hfsplus:amd64:
libguestfs-hfsplus:amd64 depends on libguestfs0 (= 1:1.36.13-1ubuntu3.2); however:
  Package libguestfs0:amd64 is not configured yet.

dpkg: error processing package libguestfs-hfsplus:amd64 (--configure):
dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              Setting up openjdk-8-jre-headless:amd64 (8u191-b12-0ubuntu0.18.04.1) ...
Installing new version of config file /etc/java-8-openjdk/security/java.security ...
Setting up openjdk-11-jre:amd64 (10.0.2+13-1ubuntu0.18.04.4) ...
Setting up libwebkit2gtk-4.0-37:amd64 (2.22.4-0ubuntu0.18.04.1) ...
dpkg: dependency problems prevent configuration of libguestfs-tools:
libguestfs-tools depends on libguestfs0 (= 1:1.36.13-1ubuntu3.2); however:
  Package libguestfs0:amd64 is not configured yet.
libguestfs-tools depends on libguestfs-perl (= 1:1.36.13-1ubuntu3.2); however:
  Package libguestfs-perl is not configured yet.

dpkg: error processing package libguestfs-tools (--configure):
dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              No apport report written because MaxReports is reached already
                                                                                                                            dpkg: dependency problems prevent configuration of libguestfs-xfs:amd64:
libguestfs-xfs:amd64 depends on libguestfs0 (= 1:1.36.13-1ubuntu3.2); however:
  Package libguestfs0:amd64 is not configured yet.

dpkg: error processing package libguestfs-xfs:amd64 (--configure):
dependency problems - leaving unconfigured
Processing triggers for initramfs-tools (0.130ubuntu3.5) ...
update-initramfs: Generating /boot/initrd.img-4.15.0-39-generic
sudo apt-get upgradeProcessing triggers for libc-bin (2.27-3ubuntu1) ...
Errors were encountered while processing:
lvm2
libguestfs0:amd64
libguestfs-reiserfs:amd64
libguestfs-perl
libguestfs-hfsplus:amd64
libguestfs-tools
libguestfs-xfs:amd64
E: Sub-process /usr/bin/dpkg returned an error code (1)


Не подскажите что это за ошибки и как их лечить ?

Спасибо!
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
 
Reply to this topicStart new topic
Ответов(1 - 2)
rayder
Nov 28 2018, 21:28
  
Пост #2



Репутация:   123  
Активист
*

Группа: Пользователи
Сообщений: 249
С нами с: 16-October 06


1. такие простыни принято прятать под спойлер.
2. Там все написано же, нужно только немного почитать. А не тыкать бездумно команды (Что очень странно для человека, у которого стоит docker и nodejs).

E: The repository 'http://ppa.launchpad.net/webupd8team/sublime-text-3/ubuntu bionic Release' does not have a Release file.

E: Repository 'http://dl.google.com/linux/chrome/deb stable Release' changed its 'Origin' value from 'Google, Inc.' to 'Google LLC'
N: This must be accepted explicitly before updates for this repository can be applied. See apt-secure(8) manpage for details.

Failed to restart lvm2-lvmetad.service: Unit lvm2-lvmetad.socket is masked.
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
Elektra
Nov 28 2018, 21:30
  
Пост #3

Благодарности: 42

Репутация:   5299  
ultra active user
******

Группа: VIP
Сообщений: 20 128
С нами с: 2-April 06


Первый вариант использовать

CODE Format
sudo apt update
sudo apt upgrade


второй вариант

CODE Format
sudo apt-get --allow-releaseinfo-change update
User is offlineProfile CardPM
Go to the top of the page
+Quote Post

Reply to this topicStart new topic

 



- Упрощённая версия
Сейчас: 18th June 2019 - 20:45
Сайт не предоставляет электронные версии произведений, а занимается лишь коллекционированием и каталогизацией ссылок, присылаемых и публикуемых на форуме нашими читателями. Если вы являетесь правообладателем какого-либо представленного материала и не желаете чтобы ссылка на него находилась в нашем каталоге, свяжитесь с нами и мы удалим её. Файлы для обмена предоставлены пользователями сайта.