Здравствуйте Гость ( Вход | Регистрация ) | Форум в сети 4575-й день

> Выгрузка в дбф нового отчёта по ЕСВ для Бух учёта 46.1, Ошибка при выгрузке в дбф нового отчёта о ЕСВ ХЕЛП!

Nysha1210
Sep 10 2018, 15:37
  
Пост #1



Репутация:   1  
Новачек


Группа: Пользователи
Сообщений: 34
С нами с: 11-July 12


Всем привет. Поставила обновление на Бух учёт для Украины новое 46.1. Бухгалтеру нужно выгружать новый ЕСВ в дбф формате. Переделала новый отчёт с учётом прошлой выгрузки в дбф.
Но выгрузить не получается ((( Уже всё перепробовала.
Выдаёт одну и ту же ошибку :

{Отчет.РегламентированныйОтчетЕдиныйСоциальныйВзнос.Форма.ФормаОтчета2018.Форма(7231)}: Поле объекта не обнаружено (T6T1RДРФО)
Если Не ЗначениеЗаполнено(Строка[ТекИдГруппы + "ДРФО"])

Не могу найти в чём ошибка в программе.
Помогите, плиз!
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
 
Reply to this topicStart new topic
Ответов(1 - 3)
Vitaliy_y
Sep 10 2018, 15:45
  
Пост #2



Репутация:   94  
Cтаршой
***

Группа: Пользователи
Сообщений: 725
С нами с: 3-July 07


что отладчик говорит про ТекИдГруппы?, скорее всего макет изменился и нет там такой группы.
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
Nysha1210
Sep 10 2018, 15:47
  
Пост #3



Репутация:   1  
Новачек


Группа: Пользователи
Сообщений: 34
С нами с: 11-July 12


(Vitaliy_y @ Sep 10 2018, 13:45) *

что отладчик говорит про ТекИдГруппы?, скорее всего макет изменился и нет там такой группы.

Группа такая есть. Возможно фонит при проверке по Функции ОтказПриПроверкеРеквизитовдлявыгрузкиDBF(). Но не могу найти. Макет в таблице 6 не поменялся по строкам.

ТекИдГруппы = мИдГруппы6;
мСтруктураМногострочныхРазделов.Свойство(ТекИдГруппы, СтруктураГруппы);
Если НЕ ТаблицаМногострочнойЧастиПуста(СтруктураГруппы, ТекИдГруппы) Тогда
Для каждого Строка Из СтруктураГруппы Цикл
Если Не ЗначениеЗаполнено(Строка[ТекИдГруппы + "ДРФО"])
ИЛИ Не ЗначениеЗаполнено(Строка[ТекИдГруппы + "ФИО"])
ИЛИ Не ЗначениеЗаполнено(Строка[ТекИдГруппы + "Имя"]) Тогда

Отказ = Истина;
Сообщить(НСтр("ru = 'Таблица '; uk = 'Таблиця'") + Сред(ТекИдГруппы,2,1) + ", "
+ НСТР("ru = 'строка '; uk = 'рядок '") + (СтруктураГруппы.Индекс(Строка) + 1) + ": "
+ НСТР("ru = 'не заполнен код ДРФО или фамилия или имя сотрудника!'; uk = 'не заповнений код ДРФО або призвище або ім''я співробітника!'"));

КонецЕсли;
КонецЦикла;
КонецЕсли;

А это описание группы:

ДобавленнаяСтрока[мИдГруппы6+"ДРФО"] = ОбработатьДРФО(ВыборкаТаблица6.КодПоДРФО);
Если ВыборкаТаблица6.ФизЛицо.Пол = Перечисления.ПолФизическихЛиц.Мужской Тогда
ДобавленнаяСтрока[мИдГруппы6+"МЖ"] = "Ч";
ИначеЕсли ВыборкаТаблица6.ФизЛицо.Пол = Перечисления.ПолФизическихЛиц.Женский Тогда
ДобавленнаяСтрока[мИдГруппы6+"МЖ"] = "Ж";
КонецЕсли;
ДобавленнаяСтрока[мИдГруппы6+"Гражданин"] = ВыборкаТаблица6.Гражданин;

ДобавленнаяСтрока[мИдГруппы6+"ФИО"] = ВыборкаТаблица6.ФизЛицоФио;
ДобавленнаяСтрока[мИдГруппы6+"Имя"] = ВыборкаТаблица6.ФизЛицоИмя;
ДобавленнаяСтрока[мИдГруппы6+"Отчество"] = ВыборкаТаблица6.ФизЛицоОтчество;

ДобавленнаяСтрока[мИдГруппы6+"Категория"] = ВыборкаТаблица6.КодКатегорииЗЛ;
ДобавленнаяСтрока[мИдГруппы6+"ТипСтавки"] = 13;

ДобавленнаяСтрока[мИдГруппы6+"МесяцГод"] = ВыборкаТаблица6.Период;

ДобавленнаяСтрока[мИдГруппы6+"КвоБольничных"] = 0;
ДобавленнаяСтрока[мИдГруппы6+"КвоБезЗП"] = 0;

ДобавленнаяСтрока[мИдГруппы6+"СуммаНачислено"]= 0;
ДобавленнаяСтрока[мИдГруппы6+"СуммаНачисленоМаксБаза"] = 0;

ДобавленнаяСтрока[мИдГруппы6+"СуммаВзносовУдержано"] = 0;
ДобавленнаяСтрока[мИдГруппы6+"СуммаВзносовНачислено"] = ДоначислениеНалогФОТ;

ДобавленнаяСтрока[мИдГруппы6+"СуммаРазницы"] = ДоначислениеФОТ;


ДобавленнаяСтрока[мИдГруппы6+"ТрудКнижка"] = ВыборкаТаблица6.ПризнакНаличияТрудовойКнижки;
Если НЕ СписокРаботниковСоСпецСтажем.НайтиПоЗначению(ВыборкаТаблица6.Сотрудник.ФизЛицо) = Неопределено Тогда
ДобавленнаяСтрока[мИдГруппы6+"СпецСтаж"] = 1;
КонецЕсли;
ДобавленнаяСтрока[мИдГруппы6+"КвоТрудОтношений"] = 0;
ДобавленнаяСтрока[мИдГруппы6+"НовоеРМ"] = ВыборкаТаблица6.ПринятНаНовоеРабочееМесто;

ДобавленнаяСтрока[мИдГруппы6+"НеполноеРВ"] = ВыборкаТаблица6.СокращенноеРабочееВремя;




Сообщение отредактировал Nysha1210 - Sep 10 2018, 15:51
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
VladRus
Sep 12 2018, 12:51
  
Пост #4

Благодарности: 2004

Репутация:   3188  
Long live rock'n'roll .!..!
Group Icon

Группа: Модеры
Сообщений: 31 164
С нами с: 19-August 09
Меценат


upd:
Чуток времени нашлось. crazy.gif
Пробуйте
» Нажмите, чтобы показать спойлер - нажмите опять, чтобы скрыть... «
User is offlineProfile CardPM
Go to the top of the page
+Quote Post

Reply to this topicStart new topic

 



- Упрощённая версия
Сейчас: 23rd September 2018 - 20:15
Сайт не предоставляет электронные версии произведений, а занимается лишь коллекционированием и каталогизацией ссылок, присылаемых и публикуемых на форуме нашими читателями. Если вы являетесь правообладателем какого-либо представленного материала и не желаете чтобы ссылка на него находилась в нашем каталоге, свяжитесь с нами и мы удалим её. Файлы для обмена предоставлены пользователями сайта и администрация не несёт ответственности за их содержание.